Page tree
Skip to end of metadata
Go to start of metadata
  1. Make sure Java is installed on your workstation:


    • Check whether Java is already installed.

      • open Terminal application, in the open window type   java -version  and press Enter:

         Click here to expand command example...
        java -version
        $ java -version
        java version "1.8.0_144"
        Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
        Java HotSpot(TM) 64-Bit Server VM (build 25.144-b01, mixed mode)
      • If the command failed – install Java following the   Installation procedure.

  2. Install SubGit binaries.


    • Download the latest SubGit version from the website:

      https://subgit.com/download
       
    • If the files have not been extracted automatically after downloading, extract them manually by the following command:

       See unzip command example…
      unzip
      $ unzip subgit-3.2.6.zip 
      
      Archive:  subgit-3.2.6.zip
         creating: subgit-3.2.6/
        inflating: subgit-3.2.6/CHANGES.txt  
        inflating: subgit-3.2.6/README.txt  
        inflating: subgit-3.2.6/LICENSE.txt 
         creating: subgit-3.2.6/lib/
        inflating: subgit-3.2.6/lib/svnkit-1.9.0.jar 
        inflating: subgit-3.2.6/lib/jansi-1.6.jar  
        inflating: subgit-3.2.6/lib/slf4j-nop-1.7.12.jar  
        inflating: subgit-3.2.6/lib/unirest-java-1.3.0.jar
        inflating: subgit-3.2.6/lib/org.eclipse.jgit-4.5.1-sgk-SNAPSHOT_t20170104_1942.jar  
        inflating: subgit-3.2.6/lib/annotations-7.0.3.jar  
        inflating: subgit-3.2.6/lib/slf4j-api-1.7.12.jar  
        inflating: subgit-3.2.6/lib/httpclient-4.3.jar  
        inflating: subgit-3.2.6/lib/httpasyncclient-4.0-beta4.jar  
        inflating: subgit-3.2.6/lib/httpmime-4.3.jar  
        inflating: subgit-3.2.6/lib/json-20090211.jar 
        inflating: subgit-3.2.6/lib/jsch-0.1.44-1.jar 
        inflating: subgit-3.2.6/lib/JavaEWAH-0.8.3.jar
        inflating: subgit-3.2.6/lib/httpcore-4.3.jar  
        inflating: subgit-3.2.6/lib/commons-logging-1.1.3.jar  
        inflating: subgit-3.2.6/lib/commons-codec-1.6.jar  
        inflating: subgit-3.2.6/lib/httpcore-nio-4.3-beta2.jar  
        inflating: subgit-3.2.6/lib/sequence-library-1.0.3.jar  
        inflating: subgit-3.2.6/lib/sqljet-1.1.10.jar  
        inflating: subgit-3.2.6/lib/jna-4.1.0.jar  
        inflating: subgit-3.2.6/lib/jna-platform-4.1.0.jar  
        inflating: subgit-3.2.6/lib/trilead-ssh2-1.0.0-build221.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.connector-factory-0.0.7.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.svnkit-trilead-ssh2-0.0.7.jar
        inflating: subgit-3.2.6/lib/antlr-runtime-3.4.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.core-0.0.7.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.usocket-jna-0.0.7.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.usocket-nc-0.0.7.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.sshagent-0.0.7.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.pageant-0.0.7.jar  
        inflating: subgit-3.2.6/lib/platform-3.4.0.jar  
        inflating: subgit-3.2.6/lib/translator-3.2.6.jar
        inflating: subgit-3.2.6/lib/svngitkit-2.3.0-SNAPSHOT_918ad5e.jar  
         creating: subgit-3.2.6/lib/licenses/
        inflating: subgit-3.2.6/lib/licenses/LICENSE-ANTLR.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-JNA.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-TRILEAD.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-JSCH.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-SEQUENCE.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-JANSI.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-JGIT.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-APR.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-COMMONS-CODEC.txt  
         creating: subgit-3.2.6/bin/
        inflating: subgit-3.2.6/bin/subgit  
        inflating: subgit-3.2.6/bin/subgit.bat
    • Add SubGit bin folder into system PATH variable:

      • type the following command in Terminal and press Enter:

        open
        open ~/.bash_profile
      • In the open text editor add (or change if it exists) PATH line and add export directive:

        PATH="SUBGIT_DIR/bin:${PATH}"
        export PATH

        where

             SUBGIT_DIR  – a path to SubGit directory that was extracted earlier.


      • To verify SubGit installation close Terminal application, then open it again and run   subgit --version  command:

         Click here to expand command example...
        subgit --version
        $ subgit --version
        SubGit version 3.2.6 ('Bobique') build #3714
          (c) TMate Software 2012-2017 (http://subgit.com/)

        It should show the correct SubGit version.

        If it does not  – verify all the steps above are followed precisely. If it doesn't work anyway – don't hesitate to contact us at  support@subgit.com