Page tree
Skip to end of metadata
Go to start of metadata
  1. Make sure Java is installed on your workstation: 

    • Run the command below to check if Java is installed:

      $ java -version
    •  If the command fails, that means Java is not installed. Install it by the following command:

      $ sudo yum install java
       See Java installation command output…
      apt-get install default-jre
      $ sudo yum install java
      Loaded plugins: fastestmirror
      Loading mirror speeds from cached hostfile
       * base: mirror.satellite-service.ru
       * extras: mirror.satellite-service.ru
       * updates: mirror.satellite-service.ru
      Resolving Dependencies
      --> Running transaction check
      ---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.144-0.b01.el7_4 will be installed
      --> Processing Dependency: java-1.8.0-openjdk-headless(x86-64) = 1:1.8.0.144-0.b01.el7_4 for package: 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: xorg-x11-fonts-Type1 for package: 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: libjvm.so(SUNWprivate_1.1)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: libjli.so(SUNWprivate_1.1)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: libjava.so(SUNWprivate_1.1)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: libjvm.so()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: libjli.so()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: libjava.so()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: libgif.so.4()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: libawt.so()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
      --> Running transaction check
      ---> Package giflib.x86_64 0:4.1.6-9.el7 will be installed
      --> Processing Dependency: libSM.so.6()(64bit) for package: giflib-4.1.6-9.el7.x86_64
      --> Processing Dependency: libICE.so.6()(64bit) for package: giflib-4.1.6-9.el7.x86_64
      ---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.144-0.b01.el7_4 will be installed
      --> Processing Dependency: tzdata-java >= 2015d for package: 1:java-1.8.0-openjdk-headless-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: copy-jdk-configs >= 2.2 for package: 1:java-1.8.0-openjdk-headless-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: lksctp-tools(x86-64) for package: 1:java-1.8.0-openjdk-headless-1.8.0.144-0.b01.el7_4.x86_64
      --> Processing Dependency: jpackage-utils for package: 1:java-1.8.0-openjdk-headless-1.8.0.144-0.b01.el7_4.x86_64
      ---> Package xorg-x11-fonts-Type1.noarch 0:7.5-9.el7 will be installed
      --> Processing Dependency: ttmkfdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
      --> Processing Dependency: ttmkfdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
      --> Processing Dependency: mkfontdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
      --> Processing Dependency: mkfontdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
      --> Running transaction check
      ---> Package copy-jdk-configs.noarch 0:2.2-3.el7 will be installed
      ---> Package javapackages-tools.noarch 0:3.4.1-11.el7 will be installed
      --> Processing Dependency: python-javapackages = 3.4.1-11.el7 for package: javapackages-tools-3.4.1-11.el7.noarch
      ---> Package libICE.x86_64 0:1.0.9-9.el7 will be installed
      ---> Package libSM.x86_64 0:1.2.2-2.el7 will be installed
      ---> Package lksctp-tools.x86_64 0:1.0.17-2.el7 will be installed
      ---> Package ttmkfdir.x86_64 0:3.0.9-42.el7 will be installed
      ---> Package tzdata-java.noarch 0:2017b-1.el7 will be installed
      ---> Package xorg-x11-font-utils.x86_64 1:7.5-20.el7 will be installed
      --> Processing Dependency: libfontenc.so.1()(64bit) for package: 1:xorg-x11-font-utils-7.5-20.el7.x86_64
      --> Processing Dependency: libXfont.so.1()(64bit) for package: 1:xorg-x11-font-utils-7.5-20.el7.x86_64
      --> Running transaction check
      ---> Package libXfont.x86_64 0:1.5.2-1.el7 will be installed
      ---> Package libfontenc.x86_64 0:1.1.3-3.el7 will be installed
      ---> Package python-javapackages.noarch 0:3.4.1-11.el7 will be installed
      --> Processing Dependency: python-lxml for package: python-javapackages-3.4.1-11.el7.noarch
      --> Running transaction check
      ---> Package python-lxml.x86_64 0:3.2.1-4.el7 will be installed
      --> Finished Dependency Resolution
      
      Dependencies Resolved
      
      ======================================================================================================================================================
       Package                                        Arch                      Version                                    Repository                  Size
      ======================================================================================================================================================
      Installing:
       java-1.8.0-openjdk                             x86_64                    1:1.8.0.144-0.b01.el7_4                    updates                    238 k
      Installing for dependencies:
       copy-jdk-configs                               noarch                    2.2-3.el7                                  base                        18 k
       giflib                                         x86_64                    4.1.6-9.el7                                base                        40 k
       java-1.8.0-openjdk-headless                    x86_64                    1:1.8.0.144-0.b01.el7_4                    updates                     32 M
       javapackages-tools                             noarch                    3.4.1-11.el7                               base                        73 k
       libICE                                         x86_64                    1.0.9-9.el7                                base                        66 k
       libSM                                          x86_64                    1.2.2-2.el7                                base                        39 k
       libXfont                                       x86_64                    1.5.2-1.el7                                base                       152 k
       libfontenc                                     x86_64                    1.1.3-3.el7                                base                        31 k
       lksctp-tools                                   x86_64                    1.0.17-2.el7                               base                        88 k
       python-javapackages                            noarch                    3.4.1-11.el7                               base                        31 k
       python-lxml                                    x86_64                    3.2.1-4.el7                                base                       758 k
       ttmkfdir                                       x86_64                    3.0.9-42.el7                               base                        48 k
       tzdata-java                                    noarch                    2017b-1.el7                                base                       183 k
       xorg-x11-font-utils                            x86_64                    1:7.5-20.el7                               base                        87 k
       xorg-x11-fonts-Type1                           noarch                    7.5-9.el7                                  base                       521 k
      
      Transaction Summary
      ======================================================================================================================================================
      Install  1 Package (+15 Dependent packages)
      
      Total download size: 34 M
      Installed size: 109 M
      Is this ok [y/d/N]: y
      Downloading packages:
      (1/16): copy-jdk-configs-2.2-3.el7.noarch.rpm                                                                                  |  18 kB  00:00:00     
      (2/16): giflib-4.1.6-9.el7.x86_64.rpm                                                                                          |  40 kB  00:00:00     
      (3/16): java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64.rpm                                                                    | 238 kB  00:00:00     
      (4/16): libICE-1.0.9-9.el7.x86_64.rpm                                                                                          |  66 kB  00:00:00     
      (5/16): libSM-1.2.2-2.el7.x86_64.rpm                                                                                           |  39 kB  00:00:00     
      (6/16): libXfont-1.5.2-1.el7.x86_64.rpm                                                                                        | 152 kB  00:00:00     
      (7/16): javapackages-tools-3.4.1-11.el7.noarch.rpm                                                                             |  73 kB  00:00:00     
      (8/16): libfontenc-1.1.3-3.el7.x86_64.rpm                                                                                      |  31 kB  00:00:00     
      (9/16): lksctp-tools-1.0.17-2.el7.x86_64.rpm                                                                                   |  88 kB  00:00:00     
      (10/16): ttmkfdir-3.0.9-42.el7.x86_64.rpm                                                                                      |  48 kB  00:00:00     
      (11/16): tzdata-java-2017b-1.el7.noarch.rpm                                                                                    | 183 kB  00:00:00     
      (12/16): xorg-x11-font-utils-7.5-20.el7.x86_64.rpm                                                                             |  87 kB  00:00:00     
      (13/16): python-javapackages-3.4.1-11.el7.noarch.rpm                                                                           |  31 kB  00:00:00     
      (14/16): xorg-x11-fonts-Type1-7.5-9.el7.noarch.rpm                                                                             | 521 kB  00:00:00     
      (15/16): python-lxml-3.2.1-4.el7.x86_64.rpm                                                                                    | 758 kB  00:00:01     
      (16/16): java-1.8.0-openjdk-headless-1.8.0.144-0.b01.el7_4.x86_64.rpm                                                          |  32 MB  00:00:30     
      ------------------------------------------------------------------------------------------------------------------------------------------------------
      Total                                                                                                                 1.1 MB/s |  34 MB  00:00:30     
      Running transaction check
      Running transaction test
      Transaction test succeeded
      Running transaction
        Installing : libfontenc-1.1.3-3.el7.x86_64                                                                                                     1/16 
        Installing : libICE-1.0.9-9.el7.x86_64                                                                                                         2/16 
        Installing : libSM-1.2.2-2.el7.x86_64                                                                                                          3/16 
        Installing : giflib-4.1.6-9.el7.x86_64                                                                                                         4/16 
        Installing : libXfont-1.5.2-1.el7.x86_64                                                                                                       5/16 
        Installing : 1:xorg-x11-font-utils-7.5-20.el7.x86_64                                                                                           6/16 
        Installing : ttmkfdir-3.0.9-42.el7.x86_64                                                                                                      7/16 
        Installing : xorg-x11-fonts-Type1-7.5-9.el7.noarch                                                                                             8/16 
        Installing : lksctp-tools-1.0.17-2.el7.x86_64                                                                                                  9/16 
        Installing : copy-jdk-configs-2.2-3.el7.noarch                                                                                                10/16 
        Installing : python-lxml-3.2.1-4.el7.x86_64                                                                                                   11/16 
        Installing : python-javapackages-3.4.1-11.el7.noarch                                                                                          12/16 
        Installing : javapackages-tools-3.4.1-11.el7.noarch                                                                                           13/16 
        Installing : tzdata-java-2017b-1.el7.noarch                                                                                                   14/16 
        Installing : 1:java-1.8.0-openjdk-headless-1.8.0.144-0.b01.el7_4.x86_64                                                                       15/16 
        Installing : 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64                                                                                16/16 
        Verifying  : libICE-1.0.9-9.el7.x86_64                                                                                                         1/16 
        Verifying  : 1:java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64                                                                                 2/16 
        Verifying  : giflib-4.1.6-9.el7.x86_64                                                                                                         3/16 
        Verifying  : xorg-x11-fonts-Type1-7.5-9.el7.noarch                                                                                             4/16 
        Verifying  : libSM-1.2.2-2.el7.x86_64                                                                                                          5/16 
        Verifying  : python-javapackages-3.4.1-11.el7.noarch                                                                                           6/16 
        Verifying  : tzdata-java-2017b-1.el7.noarch                                                                                                    7/16 
        Verifying  : 1:java-1.8.0-openjdk-headless-1.8.0.144-0.b01.el7_4.x86_64                                                                        8/16 
        Verifying  : python-lxml-3.2.1-4.el7.x86_64                                                                                                    9/16 
        Verifying  : libXfont-1.5.2-1.el7.x86_64                                                                                                      10/16 
        Verifying  : javapackages-tools-3.4.1-11.el7.noarch                                                                                           11/16 
        Verifying  : libfontenc-1.1.3-3.el7.x86_64                                                                                                    12/16 
        Verifying  : copy-jdk-configs-2.2-3.el7.noarch                                                                                                13/16 
        Verifying  : lksctp-tools-1.0.17-2.el7.x86_64                                                                                                 14/16 
        Verifying  : ttmkfdir-3.0.9-42.el7.x86_64                                                                                                     15/16 
        Verifying  : 1:xorg-x11-font-utils-7.5-20.el7.x86_64                                                                                          16/16 
      
      Installed:
        java-1.8.0-openjdk.x86_64 1:1.8.0.144-0.b01.el7_4                                                                                                   
      
      Dependency Installed:
        copy-jdk-configs.noarch 0:2.2-3.el7         giflib.x86_64 0:4.1.6-9.el7               java-1.8.0-openjdk-headless.x86_64 1:1.8.0.144-0.b01.el7_4  
        javapackages-tools.noarch 0:3.4.1-11.el7    libICE.x86_64 0:1.0.9-9.el7               libSM.x86_64 0:1.2.2-2.el7                                  
        libXfont.x86_64 0:1.5.2-1.el7               libfontenc.x86_64 0:1.1.3-3.el7           lksctp-tools.x86_64 0:1.0.17-2.el7                          
        python-javapackages.noarch 0:3.4.1-11.el7   python-lxml.x86_64 0:3.2.1-4.el7          ttmkfdir.x86_64 0:3.0.9-42.el7                              
        tzdata-java.noarch 0:2017b-1.el7            xorg-x11-font-utils.x86_64 1:7.5-20.el7   xorg-x11-fonts-Type1.noarch 0:7.5-9.el7                     
      
      Complete!
    • After the installation completes,  check java -version again to make sure it works normally.

       See java -version output…
      java -version
      $ java -version
      openjdk version "1.8.0_144"
      OpenJDK Runtime Environment (build 1.8.0_144-b01)
      OpenJDK 64-Bit Server VM (build 25.144-b01, mixed mode)
  2. Install SubGit binaries:
    • Download the latest SubGit version from the website:

      https://subgit.com/download

    • Extract files:

      $ unzip subgit-3.2.6.zip
       See extraction command output…
      unzip subgit
      $ unzip subgit-3.2.6.zip 
      Archive:  subgit-3.2.6.zip
         creating: subgit-3.2.6/
        inflating: subgit-3.2.6/CHANGES.txt  
        inflating: subgit-3.2.6/README.txt  
        inflating: subgit-3.2.6/LICENSE.txt  
         creating: subgit-3.2.6/lib/
        inflating: subgit-3.2.6/lib/svnkit-1.9.0.jar  
        inflating: subgit-3.2.6/lib/jansi-1.6.jar  
        inflating: subgit-3.2.6/lib/slf4j-nop-1.7.12.jar  
        inflating: subgit-3.2.6/lib/unirest-java-1.3.0.jar  
        inflating: subgit-3.2.6/lib/org.eclipse.jgit-4.5.1-sgk-SNAPSHOT_t20170104_1942.jar  
        inflating: subgit-3.2.6/lib/annotations-7.0.3.jar  
        inflating: subgit-3.2.6/lib/slf4j-api-1.7.12.jar  
        inflating: subgit-3.2.6/lib/httpclient-4.3.jar  
        inflating: subgit-3.2.6/lib/httpasyncclient-4.0-beta4.jar  
        inflating: subgit-3.2.6/lib/httpmime-4.3.jar  
        inflating: subgit-3.2.6/lib/json-20090211.jar  
        inflating: subgit-3.2.6/lib/jsch-0.1.44-1.jar  
        inflating: subgit-3.2.6/lib/JavaEWAH-0.8.3.jar  
        inflating: subgit-3.2.6/lib/httpcore-4.3.jar  
        inflating: subgit-3.2.6/lib/commons-logging-1.1.3.jar  
        inflating: subgit-3.2.6/lib/commons-codec-1.6.jar  
        inflating: subgit-3.2.6/lib/httpcore-nio-4.3-beta2.jar  
        inflating: subgit-3.2.6/lib/sequence-library-1.0.3.jar  
        inflating: subgit-3.2.6/lib/sqljet-1.1.10.jar  
        inflating: subgit-3.2.6/lib/jna-4.1.0.jar  
        inflating: subgit-3.2.6/lib/jna-platform-4.1.0.jar  
        inflating: subgit-3.2.6/lib/trilead-ssh2-1.0.0-build221.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.connector-factory-0.0.7.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.svnkit-trilead-ssh2-0.0.7.jar  
        inflating: subgit-3.2.6/lib/antlr-runtime-3.4.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.core-0.0.7.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.usocket-jna-0.0.7.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.usocket-nc-0.0.7.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.sshagent-0.0.7.jar  
        inflating: subgit-3.2.6/lib/jsch.agentproxy.pageant-0.0.7.jar  
        inflating: subgit-3.2.6/lib/platform-3.4.0.jar  
        inflating: subgit-3.2.6/lib/translator-3.2.6.jar  
        inflating: subgit-3.2.6/lib/svngitkit-2.3.0-SNAPSHOT_918ad5e.jar  
         creating: subgit-3.2.6/lib/licenses/
        inflating: subgit-3.2.6/lib/licenses/LICENSE-ANTLR.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-JNA.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-TRILEAD.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-JSCH.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-SEQUENCE.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-JANSI.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-JGIT.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-APR.txt  
        inflating: subgit-3.2.6/lib/licenses/LICENSE-COMMONS-CODEC.txt  
         creating: subgit-3.2.6/bin/
        inflating: subgit-3.2.6/bin/subgit  
        inflating: subgit-3.2.6/bin/subgit.bat 
    • Move extracted files to the /opt directory:

      $ subdo mv ./subgit-3.2.6 /opt/subgit
    • Add SubGit bin folder in PATH variable:
      • Open .bash_profile in a text editor:

        $ vi ~/.bash_profile
      • Add SubGit bin directory to PATH line:

        …
        PATH=$PATH:$HOME/.local/bin:$HOME/bin:/opt/subgit/bin
        export PATH
      • Save the file and exit text editor.
         
    • To verify SubGit installation, close current terminal session, then start again and run   subgit --version command:

       Click here to expand command example...
      subgit --version
      $ subgit --version
      SubGit version 3.2.6 ('Bobique') build #3714
        (c) TMate Software 2012-2017 (http://subgit.com/)


      It should show the correct SubGit version.
      If it does not – verify all the steps above are followed precisely. If it doesn't work anyway – don't hesitate to contact us at support@subgit.com